ВКС №1 в России, по числу внедренных проектов 2020 (TAdviser)

Обновление версии сервиса Videomost

Для обновления сервиса видеоконференций VideoMost вместе с серверной частью необходимо выполнить следующие действия:

1. Если установлен и запущен сервис Monit (настроенный на отслеживание работоспособности серверов apache2, stund, echosrvd, jconfsrvd, openfire, udprelay), необходимо его остановить:

# systemctl stop monit

2. Сделайте резервную копию конфигурационных файлов сервиса VideoMost и файла лицензии:

/usr/share/videomost/service/config/videomost.conf

/usr/share/jconfsrv/*.lic

/usr/share/jconfsrv/conference-srv.xml

Если был настроен https, то для Debian/Ubuntu рекомендуется еще сохранить файл конфигурации Apache.

Скопируйте архив с серверным ПО «VideoMost» на сервер, распакуйте его и перейдите в папку с распакованным дистрибутивом:

# tar xzf videomost-server-xxx-yyy.tar.gz

# cd videomost-server-xxx

Где:

-   xxx – идентификатор ОС (например, deb9-amd64),

-   yyy – версия дистрибутива (например, 8.2).

В данном примере файл с архивом будет иметь следующее имя: videomost-server-deb9-amd64-8.2.tar.gz, а у папки с дистрибутивом будет имя: videomost-server-deb9-amd64.

Далее команды установки будут представлены относительно этого пути.

Важно!

Если обновление выполняется с версий VideoMost 6.3 и 7.0, то необходимо предварительно установить необходимые для работы VideoMost-сервер версии 8.2 nodejs, pm2 командами

-    для Debian/Ubuntu:

# dpkg -i third-party/nodejs*.deb

# dpkg -i third-party/pm2*.deb

-   для CentOS/RHEL/RedOS:

# rpm -ihv third-party/nodejs*.rpm

# rpm -ihv third-party/pm2*.rpm

Затем обновите версию Openfire из комплекта поставки командой

-   для Debian/Ubuntu:

# dpkg -i third-party/openfire*.deb

-   для CentOS/RHEL/RedOS:

# rpm -Uhv third-party/openfire*.rpm

В процессе установки будет задан вопрос

Файл настройки «/etc/openfire/openfire.xml»

 ==> Изменён с момента установки (вами или сценарием).

 ==> Автор пакета предоставил обновлённую версию.

  Что нужно сделать? Есть следующие варианты:

   Y или I : установить версию, предлагаемую сопровождающим пакета

   N или O : оставить установленную на данный момент версию

    D      : показать различия между версиями

    Z      : запустить оболочку командной строки для проверки ситуации

 По умолчанию сохраняется текущая версия файла настройки.

*** openfire.xml (Y/I/N/O/D/Z) [по умолчанию N] ?

Необходимо ответить «N», т.е. сохранить текущую версию файла.

В файле /etc/openfire/openfire.xml должна быть строка вида

<serverURL>jdbc:mysql://localhost:3306/openfire?useUnicode=true&amp;characterEncoding=UTF-8&amp;characterSetResults=UTF-8&amp;serverTimezone=UTC</serverURL>

Если в конце строки отсутствует параметр &amp;serverTimezone=UTC , то необходимо его дописать, тем самым приведя строку к указанному виду.

Выполните рестарт сервиса openfire командой

# systemctl restart openfire

Откройте web-браузер на рабочем компьютере и перейдите по адресу:http://videomost.example.com:9090. Если откроется страница приглашения входа в Administration Console, то сервис обновился без ошибок и можно продолжить обновление. Если возникли какие-то, ошибки, то необходимо проверить правильность выполненных операций.

 

3. Обновление VideoMost-сервер выполняется командой:

-   для Debian/Ubuntu:

# dpkg -i videomost/videomost-server*deb

-   для CentOS/RHEL/RedOS:

# rpm -Uhv videomost/videomost-server*.rpm

При обновлении версий 6.x или 7.0 в процессе установки будет задан вопрос

Файл настройки «/etc/monit/conf.d/videomost»

 ==> Изменён с момента установки (вами или сценарием).

 ==> Автор пакета предоставил обновлённую версию.

  Что нужно сделать? Есть следующие варианты:

   Y или I : установить версию, предлагаемую сопровождающим пакета

   N или O : оставить установленную на данный момент версию

       D      : показать различия между версиями

       Z      : запустить оболочку командной строки для проверки ситуации

 По умолчанию сохраняется текущая версия файла настройки.

*** videomost (Y/I/N/O/D/Z) [по умолчанию N] ?

Необходимо ответить «N», т.е. сохранить текущую версию файла.

По окончании обновления необходимо удалить файл /etc/monit/conf.d/videomost.dpkg-dist (имя файла приведено для ОС Debian/Ubuntu).

При обновлении версий 6.x или 7.0 в файле /usr/share/videomost/service/config/videomost.conf необходимо в строке

define('SKIN', 'rbd');

заменить rbd на zskin. Строка должна иметь вид

 define('SKIN', 'zskin');

После чего выполнить рестарт сервиса apache

-   для Debian/Ubuntu:

# systemctl restart apache2

-   для CentOS/RHEL/RedOS:

# systemctl restart httpd

4. Проверьте, на каких IP-адресах запущены сервисы stund и echodaemon (актуально для серверов с несколькими сетевыми интерфейсами). Данные сервисы должны быть запущены на внешнем IP-адресе если таковой имеется.

5. Если в файле /usr/share/jconfsrv/conference-srv.xmlбыли установлены дополнительные параметры, то необходимо перенести их из файла резервной копии, созданного перед обновлением.

6. Если вы использовали функцию «Корпоративный ростер» (подробнее в разделе «Настройка LDAP»), необходимо выполнить следующие действия:

Перейти в каталог /usr/share/videomost/service и выполнить команды:

# php indexcli.php 'request=ext/vmi&task=migrate'

# php indexcli.php 'request=ext/vmi&task=deleteoldgroups'

7. Если перед обновлением было смонтировано Хранилище, то необходимо его отмонтировать.

8. Если есть настроенный сервис Monit, запустите его:

# systemctl restart monit

 

Важно!

Для CentOS/RHEL/RedOS рекомендуется выполнить перезагрузку ОС.